Unscheduled downtime
Incident Report for Prorenata Journal
Resolved
This incident has been resolved.
Posted Dec 18, 2019 - 14:05 CET
Update
We are up again. Monitoring.
Posted Dec 18, 2019 - 14:01 CET
Investigating
We are currently investigating this issue.
Posted Dec 18, 2019 - 13:57 CET
This incident affected: Prorenata Journal.