Server response problems
Incident Report for ProReNata AB
Resolved
This incident has been resolved.
Posted 5 months ago. Apr 15, 2019 - 16:23 CEST
Update
We are continuing to investigate this issue.
Posted 5 months ago. Apr 15, 2019 - 16:22 CEST
Investigating
We are currently experiencing problems and are investigating the causes behind it.
Posted 5 months ago. Apr 15, 2019 - 16:15 CEST
This incident affected: ProReNata Journal.