Unscheduled downtime
Incident Report for Prorenata Journal
Resolved
The incident is resolved. We suspect a network glitch.
Posted Apr 15, 2020 - 14:12 CEST
Investigating
We are currently investigating this issue.
Posted Apr 15, 2020 - 14:07 CEST
This incident affected: Prorenata Journal.