Degraded performance
Incident Report for Prorenata Journal
Resolved
This incident has been resolved.
Posted Apr 30, 2020 - 08:08 CEST
Investigating
We are currently investigating this issue.
Posted Apr 30, 2020 - 07:34 CEST
This incident affected: Prorenata Journal.