Filuppladdning till Prorenata Journal fungerar ej
Incident Report for Prorenata Journal
Resolved
This incident has been resolved.
Posted Nov 18, 2020 - 17:25 CET
Identified
The issue has been identified and a fix is being implemented.
Posted Nov 18, 2020 - 15:22 CET
Investigating
We are currently investigating this issue.
Posted Nov 18, 2020 - 14:52 CET
This incident affected: Prorenata Journal.