We are experiencing problems with file uploads to Prorenata
Incident Report for Prorenata Journal
Resolved
This incident has been resolved.
Posted Apr 03, 2020 - 09:12 CEST
Identified
The issue has been identified and a fix is being implemented.
Posted Apr 03, 2020 - 09:04 CEST
Investigating
We are currently investigating this issue.
Posted Apr 03, 2020 - 08:51 CEST
This incident affected: Prorenata Journal.